The Yaj Computers Portal

Post Top Ad

Post Top Ad

Sunday, January 11, 2015

No Network Access – Avast To Blame


No Network Access – Avast To Blame


So, a little while ago, I had a big networking problem with my computer. At first, I had no idea what the cause was, and how to fix it,So here's how to solve that. Here’s the problem & here’s the solution.
Symptoms: Not able to connect to Internet/network, including using Wi-Fi, Ethernet cable and an external modem, or can only access HTTPS websites
May have already tried: Re-installing drivers, calling your ISP to check for outages or correct settings, tried using a static IP to rule out dodgy router not assigning IPsHave you installed, uninstalled, updated or just used avast recently? Then I think I know the cause of your problem.Now, I’m not sure how I ended up solving this, either by trial and error, or maybe something I read on a forum, so props to the source and anyone else who found it. The cause of your problem is avast Antivirus has created phantom clones of your network modules, so that, I assume, it can channel all traffic through them and vet it before it goes anywhere. In theory, this idea is good, because it means that avast can protect you from any threats before they get to you, and spot any suspicious behavior coming from any programs on your computer. The problem occurs when it breaks down. If you uninstall avast, it doesn't seem to be able to remove the phantoms and so, it’s like all your traffic in & out is being sent to an unmanned cash register at the supermarket(and it’s not self-serve either!). They’re ready to go, but they've got no idea what they’re doing!

So, how do you find out if this is your problem? First you have to open Device Manager, which can be found in the Control Panel. Then expand the label “Network Adapters”. If you see two of any of the adaptors, then I think you’ve found your problem. If you have a closer look, you notice that one of the two have avast mentioned in its name. It’ll say something like “Atheros AR8152/8158 PCI-E Fast Ethernet Controller (NDIS 6.20) – avast! Free Antivirus”. What you need to do is right-click on that one, and chooses uninstall. It’ll ask you if you’re sure, and you are! Just make sure you don’t delete the other one too. Only delete the ones that say avast. Even if you’re planning on reinstalling avast, you need to do this, because when it happened to me, I reinstalled avast and it didn’t reconnect with the clones, but instead said that there was something wrong with the network shield.
Like I said before, you don’t have to have uninstalled avast to get this problem. I know of people who have had this problem after updating it or installing it for the first time.
I have always thought avast was pretty great. It’s been much more reliable and fully featured than other antiviruses that we’ve paid for. But in the last little while, I have found it to have become increasingly invasive, painful to use, and monetised. It’s constantly trying to find ways of making money out of you, not just by upgrading your coverage. It’s starting to really annoy me, and problems like this only add to the bad taste it’s leaving me with.

No comments:

Post a Comment

You May Like to Read:

You May Like to Read:

Follow by Email

Popular Posts